[Mimedefang] DBI not working, use DBI;causing mimedefang to b reak 2.52 - Got it

Tory Blue tmblue at responsys.com
Mon Jul 4 02:06:52 EDT 2005

 It was simply permissions, well not simply however I had a brain storm this
afternoon and came back and tried to run my test scripts as defang and well
they failed with a can't locate Blab blah DBI blah blah at .. 

So I checked the permissions and low and behold I'm golden! So while it
worked as root, it would not run as Defang and thus just adding the use DBI;
at the top of my filter, caused it to try to load DBI and thus fail
(although it may over react in this instance, someone should probably take a
look at figure out a way for mimedefang to get past not being able to load a
perl module).

Anyways for those that have issues using DBI as your mimedefang user, after
installing things from cpan try

chmod -R go=u-w /usr/lib/perl* /usr/local/lib/perl* /www/perl

That just may cure your issues (if your installing as root)


Now I can play some more w00t!

-----Original Message-----
From: mimedefang-bounces at lists.roaringpenguin.com
[mailto:mimedefang-bounces at lists.roaringpenguin.com] On Behalf Of Tory Blue
Sent: Sunday, July 03, 2005 2:11 PM
To: 'mimedefang at lists.roaringpenguin.com'
Subject: [Mimedefang] DBI not working, use DBI;causing mimedefang to break

I've made a bunch of tweaks recently and things are running well, however I
had a heck of a time getting all the various components of graphdefang to
install correctly, gd/GD to be specific and well I decided to abandon that
and just push the various things into a DB and then do some PHP or other to
create the reports I want to see.

However, the minute I add use DBI; to my mimedefang-filter things start
failing. Without it , I do a connect, helo mail from (forged) and am slapped
down, adding use DBI; I can helo/mailfrom/rcptto/data and then the system
just sits there, never finishes, never accepts the mail as being done, until
I remove use DBI and hup my Mail processes, then the system closes the
connections and delivers the forged email.

For example, until I remove use DBI; from my mimedefang-filter, the
connection does not end, sits here and I end up with slaves being used up
until there are no more, as inbound connections are waiting the 250 (hello

Jul  3 14:05:41 gateway2 sendmail[14138]: j63L5Nxk014138:
from=tmblue at domain.com, size=26, class=0, nrcpts=1,
msgid=<200507032105.j63L5Nxk014138 at host.domain.com>, proto=SMTP, daemon=MTA,

But I'm not leaving anything out, when I say, if I add use DBI; at the
beginning of my filter, things stop working (just the use DBI;, with no
other arguments, there is nothing calling DBI and it still breaks).

# -*- Perl -*-
#use DBI;  <--- commented out and it works, uncomment and mimedefang-filter
breaks, any ideas?
# mimedefang-filter
# Suggested minimum-protection filter for Microsoft Windows clients, plus
# SpamAssassin checks if SpamAssassin is installed.
# Copyright (C) 2002 Roaring Penguin Software Inc.
# This program may be distributed under the terms of the GNU General
# Public License, Version 2, or (at your option) any later version.
# $Id: suggested-minimum-filter-for-windows-clients,v 1.80 2004/03/26
19:23:16 dfs Exp $
Visit http://www.mimedefang.org and http://www.roaringpenguin.com
MIMEDefang mailing list
MIMEDefang at lists.roaringpenguin.com

More information about the MIMEDefang mailing list