[Mimedefang] Could not connect to clamd daemon at /var/spool/MIMEDefang/clamd.sock

Anthony Griffiths neuronetv at gmail.com
Fri May 6 17:06:31 EDT 2022

I'm running mimedefang-2.86 on centos 7.
I can't get mimedefang to work with clamav-0.103.5. In the maillog I always get:

mimedefang.pl[3520]: 245Fuojh003739: Could not connect to clamd daemon
at /var/spool/MIMEDefang/clamd.sock
mimedefang.pl[3520]: 245Fuojh003739: Problem running virus scanner:
code=999, category=cannot-execute, action=tempfail
mimedefang.pl[3520]: 245Fuojh003739: filter:  tempfail=1
mimedefang[3715]: 245Fuojh003739: Tempfailing because filter instructed us to
sendmail[3739]: 245Fuojh003739: Milter: data, reject=451 4.3.0 Problem
running virus-scanner

when I ran ./configure to install mimedefang it detected clamd and said:
Make sure clamd runs as the defang user!
how does one do this?
I tried:
# runuser -l defang -c/usr/local/sbin/clamd &
but md still throws the same error. it's not creating the clamd.sock file.
how do I fix this? thanks for any help.

More information about the MIMEDefang mailing list