[Mimedefang] MIMEDefang 2.70 compile error

Eric Laizure starfire at emeden.net
Sun Jul 11 13:49:29 EDT 2010

I apparently get the same error on 2.71. This doesn't make sense since 2.68 and earlier worked fine. I would try 2.69, but I can't find a source. 

Eric Laizure

-----Original Message-----
From: Eric Laizure <starfire at emeden.net>
Sent: Wednesday, June 30, 2010 1:58 PM
To: mimedefang at lists.roaringpenguin.com
Subject: MIMEDefang 2.70 compile error


I recently downloaded the 2.70 version and attempted to compile it with 
the following options on Fedora 12 x64:

./configure --prefix=/usr --with-user=smmsp 
--with-quarantinedir=/var/spool/MD-Quarantine --mandir=/usr/share/man ;

When I do, I get the following error:

gcc -g -O2 -Wall -Wstrict-prototypes  -D_REENTRANT -D_GNU_SOURCE 
-DPERL_USE_SAFE_PUTENV -DDEBUGGING -fno-strict-aliasing -pipe
-I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 
-I/usr/include/gdbm  -I/usr/lib64/perl5/5.10.0/x86_64-linux-thr
-DSAFE_EMBED_PERL -DPERL_PATH=\"/usr/bin/perl\" 
-DMIMEDEFANG_PL=\"/usr/bin/mimedefang.pl\" -DRM=\"/bin/rm\" 
-DVERSION=\"2.70\" -DSPOOLDIR=\"/var/spool/MIMEDefang\" 
-DQDIR=\"/var/spool/MD-Quarantine\" -DCONFDIR=\"/etc/mail\" 
-I../sendmail-8.14.4/include -c -o embperl.o ./embperl.c
./embperl.c:20: warning: function declaration isn a prototype
gcc -g -O2 -Wall -Wstrict-prototypes  -D_REENTRANT -D_GNU_SOURCE 
-DPERL_USE_SAFE_PUTENV -DDEBUGGING -fno-strict-aliasing -pipe 
-I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 
-I/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/CORE  -pthread 
-DPERL_PATH=\"/usr/bin/perl\" -DMIMEDEFANG_PL=\"/usr/bin/mimedefang.pl\" 
-DRM=\"/bin/rm\" -DVERSION=\"2.70\" -DSPOOLDIR=\"/var/spool/MIMEDefang\" 
-DQDIR=\"/var/spool/MD-Quarantine\" -DCONFDIR=\"/etc/mail\" 
-I../sendmail-8.14.4/include -c -o xs_init.o ./xs_init.c
./xs_init.c: In function s_init
./xs_init.c:15: error: y_perlundeclared (first use in this function)
./xs_init.c:15: error: (Each undeclared identifier is reported only once
./xs_init.c:15: error: for each function it appears in.)
./xs_init.c:15: warning: passing argument 3 of erl_newXSfrom incompatible 
pointer type
/usr/lib64/perl5/5.10.0/x86_64-linux-thread-multi/CORE/proto.h:1500: note:

expected SUBADDR_tbut argument is of type oid (*)(struct CV *)
make: *** [xs_init.o] Error 1

I'm attaching the logs I made of this. Any idea what I might have done 
wrong or how I can fix this?


More information about the MIMEDefang mailing list