[Mimedefang] Problem with permissions

Bill Maidment bill at maidment.vu
Tue Sep 9 22:18:52 EDT 2008

On Tue, 9 Sep 2008 18:58:28 -0700, John Nemeth wrote
> On Jan 31,  2:39am, "Bill Maidment" wrote:
>      This can happen when MIMEDefang isn't running (i.e. crashed).  Use
> "ps" to see if MIMEDefang is running and/or check your logs to see if
> MIMEDefang has given any errors.
>      BTW, you don't what OS you are running on.  I have found on
> Solaris that you have to use Unix::Syslog.  If you use Sys::Syslog, you
> will get this problem.

I'm running Fedora 9. mimedefang is still running OK with no warnings.
I installed perl-Unix-Syslog.

17214 ?        S      0:00 /usr/local/bin/mimedefang-multiplexor -p
/var/spool/MIMEDefang/mimedefang-multiplexor.pid -m 4 -x 10 -U defang -b 600 -q 50 -l -s
17216 ?        S      0:00 /usr/bin/perl /usr/local/bin/mimedefang.pl -server
17232 ?        Sl     0:00 /usr/local/bin/mimedefang -P
/var/spool/MIMEDefang/mimedefang.pid -m
/var/spool/MIMEDefang/mimedefang-multiplexor.sock -R 1 -U defang -H -t -q -p
17249 ?        S      0:00 /usr/bin/perl /usr/local/bin/mimedefang.pl -server
17254 ?        S      0:00 /usr/bin/perl /usr/local/bin/mimedefang.pl -server
17255 ?        S      0:00 /usr/bin/perl /usr/local/bin/mimedefang.pl -server

but i still get

Starting sendmail: 451 4.0.0 /etc/mail/sendmail.cf: line 1804: Xmimedefang: local socket
name /var/spool/MIMEDefang/mimedefang.sock unsafe: Permission denied

I even re-installed sendmail, but still no difference.
I think I'll go for a walk to clear my head.

Bill Maidment
Maidment Enterprises Pty Ltd
One-armed Consultant to Elgas Ltd
Phone: 02 9904 3364

More information about the MIMEDefang mailing list