[Mimedefang] Frequent signal 11 crashes

Mișu Moldovan dumol at gnome.ro
Thu Oct 9 15:03:37 EDT 2008

"Kayne Kruse" <kkruse at pointone.com> a scris: 
> > I've tried the setup on a very solid production machine 
> > (server-quality hardware, uptime over 100 days) with a 
> > hardened Gentoo machine where the kernel is patched with 
> > grsecurity and PaX and everything is compiled with a hardened 
> > toolchain with PIC/PIE. The crashes happen very frequent 
> > there (but not 100% reproducible), MIMEDefang rarely gets to 
> > process two or three mail before dying with this message in the log:
> > 
> Just my experience with 'stable' machines that suddenly start throwing sig 11's, check the power supply, or run memtest on the box.  I have all too often found that a dying power supply can fix these all too easily and is very often the first thing overlooked when your trying to troubleshoot these.  Believe me, I have had 3 boxes throw 11's and stopped doing so after replacing it tho mine were usually after some kind of system strain ( e.g. bootup fscks, high load or cpu intensive apps).

I know, I know, it looks like it could be a hardware problem but I'm
quite sure it is not. This DELL machine is a 2U server that continously
scans mail traffic with ClamAV and SpamAssassin and currently has an
uptime of 196 days with an average load of 2 (judging by the Cacti
graphs for the past months). And the crashes happen on my workstation
too, it's only the syslog messages that differ, because of the
grsecurity patch.

However, I've tried other milters on my workstation and one of them,
milter-regexp, crashes in about the same way as MIMEDefang, so I'm also
investigating Axigen's milter implementation, maybe there is something
out of order with the MTA. For the curious, the backtrace for

Core was generated by `/usr/bin/milter-regex -u milter -p
inet:44444 at localhost -c /etc/mail/milter-reg'. Program terminated with
signal 11, Segmentation fault.
#0  0xb7edf028 in strcmp () from /lib/libc.so.6
(gdb) bt
#0  0xb7edf028 in strcmp () from /lib/libc.so.6
#1  0x0804e4c8 in smfi_getsymval (ctx=0x805a108, symname=0x8051e79
#"{rcpt_mailer}") at smfi.c:825 2  0x0804a019 in check_macros
#(ctx=0x805a108, context=0x805a230, phase=0x8051b94 "envrcpt") at
#milter-regex.c:305 3  0x0804a196 in cb_envrcpt (ctx=0x805a108,
#args=0x8060c68) at milter-regex.c:463 4  0x08050197 in st_rcpt
#(g=0xb763d364) at engine.c:1294 5  0x08051115 in mi_engine
#(ctx=0x805a108) at engine.c:404 6  0x0804e2c4 in mi_handle_session
#(ctx=0x805a108) at handler.c:45 7  0x0804cf11 in
#mi_thread_handle_wrapper (arg=0x805a108) at listener.c:579 8
#0xb7fa817b in ?? () from /lib/libpthread.so.0 9  0x0805a108 in ?? ()

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.mimedefang.org/pipermail/mimedefang_lists.mimedefang.org/attachments/20081009/0894777e/attachment.sig>

More information about the MIMEDefang mailing list