[Mimedefang] mimedefang and simple spamassassin test

Steffen Kaiser skmimedefang at smail.inf.fh-bonn-rhein-sieg.de
Tue May 6 03:17:23 EDT 2008

Hash: SHA1

On Mon, 5 May 2008, Jon Rowlan wrote:

> No, Debian, Sarge I think.

;-) I asked because you used backslashes instead of forward slashes.
Did you used them somewhere else, too? I mean the backslashes?

> MD (headers cannot be replaced by SA for example). So it seems to me

This is not by control, but by design; SA returns a modified mail, but 
MIMEDefang does not replace it by the one provided by SA, because other 
changes you made during the processing would be lost.

> that the sa-mimedefang file overrides the local.cf one. It makes sense
> to me to leave both files in case I want to use SA with another app.
>> Check if the spamassassin rules can be read:
>> su mdefang -c 'spamassassin --lint -C /etc/mail/sa-mimdefang.cf -x'
> I have tried ...
> su defang -c 'spamassassin --lint -D -C /etc/spamassassin/local.cf -x'
> and
> su defang -c 'spamassassin --lint -D -C /etc/mail/sa-mimdefang.cf -x'
> with and without the "-D" and neither give me any output on screen ???
> Do I need to view a log somewhere?

No, no log file.
If there is no output _without_ the -D flag, it means OK (good ol' Unix 
style). No output _with_ -D flag is bad and I don't know what this can 
mean, because there should be at least some debugging output, like:

[9219] dbg: logger: adding facilities: all
[9219] dbg: logger: logging level is DBG
[9219] dbg: generic: SpamAssassin version 3.1.7-deb

Maybe you retry with -p instead of -C . It makes no difference in my 
system (Debian Etch), though. What's the exit code, BTW?

Do you get any output running the --lint -D command as root? Exit code 
other than 0 (zero)?

>> I think you need to add a
>> describe BAD_TEST             Local rule BLA BLA
> I tried this and no change.

Well, it seems that spamassassin does not come up at all.


- -- 
Steffen Kaiser
Version: GnuPG v1.4.6 (GNU/Linux)


More information about the MIMEDefang mailing list