[Mimedefang] SA-Bayes not working..

Richard J. Kieran Rkieran at rhnet.org
Thu Jun 26 09:09:01 EDT 2008

Tomasz Ostrowski <tometzky at batory.org.pl> writes:
>On 2008-06-25 19:01, Richard J. Kieran wrote:
>> No sign of Bayes. It's not because I'm a whitelisted recipient, is
>> it?
>Could be - if you are in a whitelist there's no point in computing
>bayes, which is expensive, right? Test it.
I ran quite a few tests, and BAYES never showed up. I perusing the logs, I found this:

/var/log/maillog:Jun 26 08:24:06 vfdr mimedefang-multiplexor[31847]: Slave 1 stderr: config: path "/root/.spamassassin" is inaccessible: Permission denied

It has been doing it from the beginning. Mostly it doesn't seem to affect anything, but could it be a factor in the Bayes problem? I thought I had solved it, but I think I just forgot about it. The file in question does not exist, and with the setup I
have it should not be accessed. I think I ran into this on another test server and it was trivial to fix, but since going from FreeBSD to CentOS, many things are different... I Googled the message and found:

> Using mimedefang-2.63 ...
> After upgrading from SpamAssassin-3.2.2 to SpamAssassin-3.2.4
> I'm getting mimedefang-multiplexor errors:
>  mimedefang-multiplexor[8089]: Slave 5 stderr: config: path
>  "/root/.spamassassin" is inaccessible: Permission denied

Because the mimedefang through spamassassin want
to write bayes database (bayes_seen and bayes_toks)

Value by default for use_bayes is 1 in file 

So I turned off Bayes in sa-mimedefang.cf but I still get the error. My head hurts!

More information about the MIMEDefang mailing list