[Mimedefang] RE: Syslog problems on Solaris 8? (Fernando Gleiser)

Dirk the Daring dirk at psicorps.org
Wed Mar 22 10:38:31 EST 2006

On Tue, 21 Mar 2006 mimedefang-request at lists.roaringpenguin.com wrote:

>From: Fernando Gleiser <fgleiser at cactus.fi.uba.ar>
>I've installed mimedefang-2.56 from source on a Solaris 8 system.
>Perl's version is 5.6.1 from sunfreeware.
>It seems to be working fine, except for one little detail: it doesn't
>log anything to syslog. the md_graphdefang_log_enable('mail', 1); line
>in mimedefan-filter is enabled and syslogd is runing, but in
>/var/log/syslog I only see sendmail's messages.
>I even tried manually setting "setlogsock('inet');" by hand on
>/usr/local/bin/mimedefang.pl and restarting mimedefang, but that didn't
>solve it.
>Any hints/pointers? I'm starting to run out of ideas.

  I second the recommendation that you use Unix::Syslog instead of
Sys::Syslog. I used Unix::Syslog when I ran MD on Solaris 8 and
never had any problems. Also, note that the target logfile *must* exist
before syslogd starts, or nothing will be written to it, even if it is
subsequently created (unless you also SIGHUP the daemon after creating
the file). Unlike many Linuxes, the syslogd on Solaris 8 will not
complain about, or create, a missing file.

  While its difficult to come by hard info, there is/was an undocumented
size limit on /etc/syslog.conf in Solaris 8 - too many lines, or too
many non-comment lines, or something like that, and the over-limit
lines get silently dropped (have no effect). So keep your syslogd.conf
short and concise. Finally, the stock syslogd in Solaris 8 does not
honor FACILITY.* constructs, only *.PRIORITY.


More information about the MIMEDefang mailing list