[Mimedefang] when libmilter uses ldap

Dilyan Palauzov Dilyan.Palauzov at aegee.org
Wed Feb 1 11:09:20 EST 2006

    I tried to compile mimedefang from source. It binds agains 
libmilter.a, which used libldap . In configure.in of Mimedefang this is 
foreseen with the lines:

    AC_MSG_CHECKING([whether libsm requires -lldap])
    RESULT=`$NM $LIBSM | grep ldap_`
    if test -z "$RESULT" ; then
        LIBS="$LIBS -lldap -llber"

however the string "ldap|" is not contained in the ./configure supplied 
with mimedefang 2.55 . I tried to autoreconf, and got the error message:
root at aegeeserv:/src/mimedefang-2.55# autoreconf
configure.in:634: warning: underquoted definition of MD_MILTER_SFIO
  run info '(automake)Extending aclocal'
  or see http://sources.redhat.com/automake/automake.html#Extending-aclocal
configure.in:645: warning: underquoted definition of MD_SM_LDAP
configure.in:656: warning: underquoted definition of MD_MILTER_SM
/usr/share/aclocal-1.9/xmms.m4:17: warning: underquoted definition of 

When I compile mimedefang 2.55, I get
    gcc -g -O2 -Wall -Wstrict-prototypes -pthread -o mimedefang 
mimedefang.o drop_privs_threaded.o utils.o rm_r.o syslog-fac.o 
-lpthread -lnsl
In function `sm_errstring':
errstring.c:(.text+0x37): undefined reference to `ldap_err2string'
collect2: ld returned 1 exit status
make: *** [mimedefang] Error 1

    In case I add manually -ldap -llber to Makefile, then it is asked 
for -lsm and so on.
    The trouble now is that this LDAP-string from cofnigure.in is not 
reflected in configure . Could somebody with understanding of the 
autotools check where the problem is?

More information about the MIMEDefang mailing list