[Mimedefang] bayes_path error

alan premselaar alien at 12inch.com
Thu Jul 17 18:34:01 EDT 2003

On 7/18/03 6:20 AM, "Fox, Randy" <Randy_Fox at csgsystems.com> wrote:

> I've been trying to fix an error in the logs:
> mimedefang-multiplexor: Slave n stderr: Cannot open bayes_path
> /var/spool/spamassassin/bayes R/W: File exists
> where n is one of the slave numbers.
> I've got bayes_path set to /var/spool/spamassassin/bayes in
> /etc/mail/spamassassin/sa-mimedefang.cf.  The 4 bayes_* data files are in
> /var/spool/spamassassin and are staying up-to-date.  I also see evidence that
> bayes is being used in the X-Spam-Score headers in messages that are flagged
> as spam.  I tried setting bayes_path to /etc/mail/spamassassin which did
> indeed stop the errors but it also stopped spamassassin from using bayes.
> I've seen references to this error on the mailing list/archives but I don't
> see any clear resolution.  Has anyone found a solution?  Because it appears to
> be working, I assume the log entry is more of an annoyance than a real error.
> Thanks,
> Randy

  I had this same problem, and it was leaving numerous lock files laying
around. (possibly a seperate issue)

The problem is with the bayes auto_learn turned on.  the work-around that
i've used (which seems to work) is to setup a cron job for user "defang"
(who i'm running mimedefang as) with the following entry:

* */4 * * * /usr/sbin/sa-learn --rebuild >& /dev/null

(this assumes that whatever flavor of unix/linux you're running that it'll
support the */4 syntax in cron)

so, every 4 minutes i run sa-learn --rebuild

it seems to have resolved the issues.

Although everything appears to be running fine with bayes currently, it
won't properly auto_learn since it can't write the data to the file, and if
i'm not mistaken, eventually it'll stop using the bayes scoring until the db
is rebuilt anyways.

hope this helps


More information about the MIMEDefang mailing list