[Mimedefang] I still have hair left

Tim Pushor timp at crossthread.com
Tue Jul 22 01:22:01 EDT 2003


I am still having trouble with my MIMEDefang. I could be wrong, but it 
seems that mimedefang.pl is not getting executed for whatever reason.

I have built two systems, both configured similarily. In fact, the only 
real difference is one is based on FreeBSD 4.7-RELEASE and one is 
FreeBSD 4.8-RELEASE. I used the same build scripts to install sendmail 
and mimedefang (2.33).

On the problem system:

When I run mimedefang with the -k switch, and then run mimedefang.pl 
manually everything seems to work. This proves that the milter, 
mimedefang is running, and that sendmail is communicating with it.

When I remove the -k switch, all I get in the sendmail log is:

Jul 21 22:45:14 calgw sendmail[5099]: h6M4jDPc005099: 
to=<timp at crossthread.com>, delay=00:00:01, pri=30425, stat=Please try 
again later

There is no other evidence.

I have compared this setup to my working setup and can't see any 
problems. The mimedefang user has the same username, uid, and gid. The 
spool directory and sockets have the same permissions. mimedefang.pl has 
the same permissions. It runs fine when I run it by hand.

My next resort is probably to start adding debugging code to mimedefang, 
but I am really hoping that someone can maybe assist pointing me in the 
right direction.


More information about the MIMEDefang mailing list