[Mimedefang] Pulling my hair out

Tim Pushor timp at crossthread.com
Sun Jul 20 20:10:01 EDT 2003


I am running MIMEDefang 2.33 on FreeBSD 4.8 under sendmail 8.12.9.

For the life of me, I cannot seem to get this to work.

I have succesfully gotten this combination running on another server 
with no problem. I have written and implemented my own milter 
applications in the past.

I am getting the dreaded 'Please try again later'. I am just at a loss 
to get any more information.

Running mimedefang.pl or /etc/mail/mimedefang-filter.pl gives no errors 
- they are syntactically correct. I have set the confMILTER_LOG_LEVEL to 
1 and 9 in my .mc file. At 9, the only thing I get in my system log is:

Jul 20 17:43:57 calgw sendmail[2433]: h6KNht9A002433: Milter: data, 
reject=451 4.7.1 Please try again later

At log level 1, I don't get anything.

I have tried running sendmail using /usr/sbin/sendmail -bD -d64.5, and I 
do get some milter related stuff when I run it:
milter_set_option(LogLevel = 9)
milter_set_option(macros.connect = j, _, {daemon_name}, {if_name}, 
milter_set_option(macros.helo = {tls_version}, {cipher}, {cipher_bits}, 
{cert_subject}, {cert_issuer})
milter_set_option(macros.envfrom = i, {auth_type}, {auth_authen}, 
{auth_ssf}, {auth_author}, {mail_mailer}, {mail_host}, {mail_addr})
milter_set_option(macros.envrcpt = {rcpt_mailer}, {rcpt_host}, {rcpt_addr})
Xmimedefang: S=60
Xmimedefang: R=60
Xmimedefang: E=300

But nothing when I try to send an email through.

Here is my sendmail.mc:

VERSIONID(`$FreeBSD: src/etc/sendmail/freebsd.mc,v 2002/11/14 
03:21:18 keramida Exp $')

FEATURE(access_db, `hash -o -T<TMPF> /etc/mail/access')
FEATURE(mailertable, `hash -o /etc/mail/mailertable')
FEATURE(virtusertable, `hash -o /etc/mail/virtusertable')
F=T, T=S:60s;R:60s;E:5m')
define(`confLOCAL_MAILER', `cyrusv2')
define(`confCW_FILE', `-o /etc/mail/local-host-names')

define(`confBIND_OPTS', `WorkAroundBrokenAAAA')
define(`confMAX_MIME_HEADER_LENGTH', `256/128')
define(`confNO_RCPT_ACTION', `add-to-undisclosed')
define(`confPRIVACY_FLAGS', `authwarnings,noexpn,novrfy')

Mimedefang is running, the socket is created.

I'm fairly frustrated, and not sure where to turn to figure out whats 
wrong. Can anyone help?

Thanks in advance!

More information about the MIMEDefang mailing list