[Mimedefang] 451 4.7.1 Please try again later and Digest::SHA1

McCarthy, Doug FIREWALL dmccart at intel.com
Tue Mar 12 19:37:34 EST 2002

Hi -

	I've been trying to install MIMEDefang and have been getting the
"4.7.1 Please try again later" error that seems pretty popular around here.
But I have another piece of information that I haven't seen anywhere else.

	When I run /usr/local/bin/mimedefang.pl by hand, I get the following
error message:

Can't locate loadable object for module Digest::SHA1 in @INC (@INC contains:
/usr/libdata/perl5/5.00503/i386-bsdos /usr/libdata/perl5/5.00503
/usr/libdata/perl5/site_perl/i386-bsdos /usr/libdata/perl5/site_perl
/usr/libdata/perl5/site_perl/i386-bsdos/include .) at
/usr/local/bin/mimedefang.pl line 26
BEGIN failed--compilation aborted at /usr/local/bin/mimedefang.pl line 26.

Now, line 26 of mimedefang.pl is

use Digest::SHA1;

and I _have_ a /usr/libdata/perl5/site_perl/Digest/SHA1.pm on that system.

It's not that it's not finding SHA1.pm; the error message for a missing file
is slightly different.  The difference lies in the "Can't locate loadable
object for" part.

I tried commenting out line 26 to see what would happen, and I got the
more-or-less expected "Usage: mimedefang.pl [-f filter] workdir | -server"

I know that this isn't the SHA1 mailing list, but I'm hoping that someone
might know what loadable object SHA1.pm might be looking for anyway.

Doug McCarthy

More information about the MIMEDefang mailing list