[Mimedefang] MIMEDefang on NetBSD

bastard child px at negative.zeroday.net
Tue Dec 11 12:26:49 EST 2001

I know that when I compiled and installed sendmail, for some reason it
didn't properly install the library files, so I had to change to the
libsmdb and libsmutil directories and run a `sh Build ; sh Build install`
and then it worked for me.


On Tue, 11 Dec 2001, Ray Phillips wrote:

> Dear MIMIDefang Users:
> Has anyone built MIMEDefang on a NetBSD system?  I've tried on
> NetBSD/alpha 1.5.2 using the unproven-pthreads-0.17nb2 package, but
> failed.  For reference, I'll append the output of ./configure and
> make to this messsage.
> Perhaps another portable threads package like GNU pth will help?
> Ray
> % ./configure
> creating cache ./config.cache
> checking for gcc... gcc
> checking whether the C compiler (gcc  ) works... yes
> checking whether the C compiler (gcc  ) is a cross-compiler... no
> checking whether we are using GNU C... yes
> checking whether gcc accepts -g... yes
> checking for a BSD compatible install... /usr/bin/install -c
> checking for perl... /usr/bin/perl
> checking for nm... /usr/bin/nm
> checking for Perl module MIME::Tools 5.410 ()... ok
> checking for Perl module MIME::WordDecoder... ok
> checking for Perl module Digest::SHA1... ok
> checking for Perl module Sys::Syslog... ok
> checking how to run the C preprocessor... gcc -E
> checking for getopt.h... yes
> checking for unistd.h... yes
> checking whether gcc accepts -pthread... no
> checking for res_init in -lresolv... yes
> checking for htons in -lsocket... no
> checking for gethostbyname in -lnsl... no
> checking for pthread_once in -lpthread... no
> checking for libmilter/mfapi.h... /usr/local/include/sendmail/libmilter/mfapi.h
> checking for antivir... /bin/false
> checking for uvscan... /bin/false
> checking for sweep... /bin/false
> checking for AvpLinux... /bin/false
> checking for libmilter.a... /usr/local/lib/libmilter.a
> checking for libsmutil.a... /usr/local/lib/libsmutil.a
> checking for libsm.a... /usr/local/lib/libsm.a
> checking for wvHtml... NOTFOUND
> checking for mail... /usr/bin/mail
> checking for sendmail... /usr/sbin/sendmail
> checking for rm... /bin/rm
> *** Virus scanner detection results:
> H+BEDV 'antivir'     NO (not found)
> NAI    'uvscan'      NO (not found)
> Sophos 'sweep'       NO (not found)
> AVP    'AvpLinux'    NO (not found)
> Could not find any recognized virus scanner... do not use
> any of the contains_virus functions in your filter.
> checking whether libmilter requires -lsfio... no
> checking whether libmilter requires -lsm... yes
> checking whether libsm requires -lldap... no
> updating cache ./config.cache
> creating ./config.status
> creating Makefile
> creating mimedefang.pl
> creating word-to-html
> creating config.h
> % /usr/local/bin/make
> gcc -g -O2  -DPERL_PATH=\"/usr/bin/perl\"
> -DMIMEDEFANG_PL=\"/usr/local/bin/mimedefang.pl\" -DRM=\"/bin/rm\"
> -DVERSION=\"2.2\" -DSPOOLDIR=\"/var/spool/MIMEDefang\"
> -I/usr/local/include/sendmail -I/usr/pkg/pthreads/include -c -o
> mimedefang.o mimedefang.c
> gcc -g -O2  -o mimedefang mimedefang.o /usr/local/lib/libmilter.a
> /usr/local/lib/libsmutil.a -lresolv  -lsm
> /usr/bin/ld: cannot open -lsm: No such file or directory
> collect2: ld returned 1 exit status
> make: *** [mimedefang] Error 1
> _______________________________________________
> MIMEDefang mailing list
> MIMEDefang at lists.roaringpenguin.com
> http://lists.roaringpenguin.com/mailman/listinfo/mimedefang

More information about the MIMEDefang mailing list